Gazebo Kinetic Not Loading

In ROS Kinetic, I ran the command roslaunch pr2_description robot_description.launch.

There were no error messages but even after many minutes awaiting Gazebo does not bring up the model. I clicked on the open Gazebo icon and it is a black screen. I also refreshed and reloaded multiple times but still does not work.

My rosject link: Learn Robotics from Zero - Robotics & ROS Online Courses

I followed the following instructions found here:

I appreciate your help.

Hi @kavi1 ,

Actually it’s not an issue, because the file you are trying to launch only start robot state publisher and joint state publisher.

In order to have the simulation, you can launch the file pointed in the notebook, which is pick_place_project_mod.launch or if you want the robot spawned only to try your own programs, use this launch file robot_spawn.launch

Be aware this rosject is quite advanced, that’s why it has a documentation in the notebooks, so you can understand everything that is happening inside the simulation.
In that case, the launch file is starting a world, spawning the robot, starting the controllers and also showing a demo.

There are many things to be taken into account, not only launching the description nodes for a robot.

Please, let me know if the indicated launch file worked for you.


Hi Kavita,

I reviewed the rosject and found a few small errors. I have corrected them and updated the notebook with proper instructions for launching the simulation.

Please use this rosject with the updates: Learn Robotics from Zero - Robotics & ROS Online Courses

Have a little patience with the loading of the simulation because it takes a little bit to load (is a heavy one).

In case you wait a lot and you still have an image like this one, then close the simulation and relaunch (sometimes Gazebo hangs).

When the simulation loads properly, it shows like this

Let me know if it works.


Thank you so much @rtellez! I truly appreciate it.

How do we launch the robots in the public simulation in the command line? I have tried the following:
source /home/simulations/public_sim_ws/devel/setup.bash

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.