Need help with setting up and running open_ai ros on local machine


I have passed more than 90 % in the open_ai ros course and wanted to set up the environment on my local machine. It have been a real challenge for several days. I would really need someone who could help me in the setup. For example currently when I run roslaunch my_turtlebot2_training start_training.launch I have following error. It would be nice if somebody cloud help me in the setup process.

Traceback (most recent call last):
File “/home/rob/catkin_ws/src/my_turtlebot2_training/src/”, line 23, in
File “/home/rob/catkin_ws/src/openai_ros/openai_ros/src/openai_ros/”, line 30, in StartOpenAI_ROS_Environment
env = gym.make(task_and_robot_environment_name)
File “/home/rob/.local/lib/python2.7/site-packages/gym/envs/”, line 140, in make
return registry.make(id)
File “/home/rob/.local/lib/python2.7/site-packages/gym/envs/”, line 105, in make
return spec.make()
File “/home/rob/.local/lib/python2.7/site-packages/gym/envs/”, line 70, in make
env = cls(*self._kwargs)
File “/home/rob/catkin_ws/src/openai_ros/openai_ros/src/openai_ros/task_envs/turtlebot2/”, line 23, in init
"/src;cd " + ros_ws_abspath + “;catkin_make”
AssertionError: The Simulation ROS Workspace path /home/user/simulation_ws DOESNT exist, execute: mkdir -p /home/user/simulation_ws/src;cd /home/user/simulation_ws;catkin_make
[turtlebot2_maze-2] process has died [pid 47107, exit code 1, cmd /home/rob/catkin_ws/src/my_turtlebot2_training/src/ __name:=turtlebot2_maze __log:=/home/rob/.ros/log/7de84f3c-e943-11ee-a616-d8bbc1543f91/turtlebot2_maze-2.log].
log file: /home/rob/.ros/log/7de84f3c-e943-11ee-a616-d8bbc1543f91/turtlebot2_maze-2

I dont understand what this directory is for. I have created it and have run catkin_make but nothing changes.

Best regards,


It looks like you’ve tried downloading the rosject from our platform and running it as is.

My guess here is your local machine does not contain the path /home/user/simulation_ws like the AssertionError tells you. That workspace is created by the construct on our platform.

You should make sure that the package you downloaded can find all of the paths that it needs.

I recommend creating a workspace with the same name or adapting the downloaded content to fit your specific path names.


It worked. Thank you!

Best regards,

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.