Problems with workspace


I just started the URDF course, and I got an issue upgrading the workspace at the beginning of Unit 1.
When I followed the instructions for the first time, everything worked without errors.

Then I reopened the tab with “The Construct” after a break. I decided to follow the instructions at the beginning of the unit again. Now I think it was unnecessary :slight_smile:

The problem itself:
catkin_make stops at this point:

then it prints strange messages:

finally, it comes out with an error

Now I can’t catkin_make the package “my_mira_description” and make a roslaunch to check it in rviz (point 1.3).

How can I fix this problem? What is happening?
Thanks in advance for your answers.

After several attempts, I launched the “urdf_visualize.launch” (Unit 1, point 1.3).

There are a lot of errors in rviz:



  1. Do you know now what helped that it gave you those catkin_make issues? Was it something you did or what exactly? Is just to know if we have to fiox something from our part.

  2. Thiose issues you have in RVIZ, could be due to the fact that you don’t have the correct fixed frameset or that the robot_state_publisher is not running. Can you check the instructions and see if you missed some step? You can also check if in the fixed frame in RVIZ selection dropdown you have all the frames there or some of them don’t appear.


Thank you for your answer.

  1. I deleted the entire contents of the catkin_ws, and launched “catkin_make” again.
  2. I forgot to choose the correct fixed frame inside the rviz. After choosing base_link as a fixed frame the problem has been solved.
1 Like

This topic was automatically closed after 19 hours. New replies are no longer allowed.