Publishing commands to '/cmd_vel/ but no movement in bot

Hi! I am working on a voice command operated bot as a project. I am using turtlebot2 as my bot and working with ros, and SpeechRecognition as the speech-to-text lib.

So far, I able to publish the recognized text into a topic and a subscriber listens into it and publishes movement commands in ‘/cmd_vel’ but my bot is not moving.

Here’s an examples of what I mean:

turtlebot@turtlebot:~/riddhi_ws$ rostopic echo /recognized_text
data: "left"

turtlebot@turtlebot:~/riddhi_ws$ rostopic echo /cmd_vel
  x: 0.0
  y: 0.0
  z: 0.0
  x: 0.0
  y: 0.0
  z: 0.2

turtlebot@turtlebot:~/turtlebot2i_ws$ rosnode list

I will be very grateful if someone can help me diagnose the problem.

Kind regards


Could you share the ROSject with the code? The git? Something? Otherwise its quite impossible to debug. Do you have a simulation or something where we can test your code? I highly recommend you to put your project inside a ROSject , is the best way to debug this.

Test the following:

  • DOes the robot move when you publish those same cmd_vel commands in that topic? Thats is the first place you have to look.

Are you publishing with the correct topic type?

Maybe try moving it with rosrun teleop_twist_keyboard teleop_twist_keyboard?

Thank you so much for your reply. I have tried running a simulation using rosject but I was unable to install PyAudio library which is required for SpeechRecognition lib, additionally I’m not sure about installing microphone driver for the same.

This is the link to the rosject:

I’ll try running those published on ‘/cmd_vel’ to move the bot

Yes, I have tried this, and the bot does respond.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.