RVIZ Model does not appear

The launch file is :


  <!-- USE: roslaunch my_mira_description urdf_visualize.launch model:='$(find myrobot_package)/urdf/myrobot.urdf' -->
  <arg name="model" default=""/>

  <param name="robot_description" command="cat $(arg model)" />

  <!-- send fake joint values -->
  <node name="joint_state_publisher_gui" pkg="joint_state_publisher_gui" type="joint_state_publisher_gui"/>

  <!-- Combine joint values -->
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher"/>

  <!-- Show in Rviz   -->
  <!--<node name="rviz" pkg="rviz" type="rviz" args="-d $(find my_mira_description)/rviz_config/urdf.rviz"/>-->
  <node name="rviz" pkg="rviz" type="rviz" args=""/>


The name of URDF file is

<?xml version="1.0"?>
<robot name="mira_new">

    <material name="brown">
            <color rgba="0.6 0.3 0 1"/>

    <material name="green">
            <color rgba=" 0 1 0 1 "/>

    <link name="base_link">
        <origin rpy="0 0 0" xyz="0 0 0"/>
            <sphere radius="0.06"/>
        <material name="brown"/>

    <link name="Head">
            <origin rpy ="0 0 0" xyz = "0 0 0.07"/>
                <sphere radius="0.06"/>
            <material name ="green"/>

    <joint name = "roll_joint" type="revolute">
        <parent link="base_link"/>
        <child link="Head"/>
        <origin xyz="0 0 0.03" rpy==" 0 0 0"/>
        <limit lower="-0.3" upper="0.3" effort="0.1" velocity="0.005"/>
        <axis xyz="1 0 0"/>


The launch command is :
roslaunch my_mira_description urdf_visualize.launch model:='$(find my_mira_description)/urdf/mira_geometric.urdf'

I am unable to change my fixed frame and make the model appear.

Hi @mamojiz97 ,

You seem to have base_link defined in your urdf file, so technically, base_link must be available in Rviz Fixed Frame dropdown menu - you can also otherwise type it in.

I have not worked with this robot yet. To which course and chapter does this task belong to?

I do not have any other suggestions right now. Try doing the above step and let me know if it worked.


Hi @girishkumar.kannan

Like you said, I do see the base_link under the drop down menu but I don’t see the model appear. I also tried to change the size of the model to check if its too small to be visible.
This course is URDF for Robot modelling.

Hi @girishkumar.kannan
I just noticed an error while launching Rviz. I am not sure what it means though.

Hi @girishkumar.kannan

I found the problem lol. I used == in one of the lines instead of =

Just wasted my time and yours

1 Like