Rviz not launching

I started my own rosject recently and have been trying to launch a URDF file in Rviz. I don’t get any errors and yet I don’t see Rviz launching either. Is there some system settings I need to do before I launch Rviz?

I first created a package using catkin_create_pkg pkg_name rospy rviz controller_manager gazebo_ros joint_state_publisher robot_state_publisher

Then created a .urdf file and a visualize.launch file. I don’t see any errors showing up when I launch nor do I see GUI tool to start.


  <!-- USE: roslaunch some_rfid visualize.launch model:='$(find myrobot_package)/urdf/myrobot.urdf' -->
  <arg name="model" default=""/>

  <param name="robot_description" command="cat $(arg model)" />

  <!-- send fake joint values -->
  <node name="joint_state_publisher_gui" pkg="joint_state_publisher_gui" type="joint_state_publisher_gui"/>

  <!-- Combine joint values -->
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher"/>

  <!-- Show in Rviz   -->
  <!--<node name="rviz" pkg="rviz" type="rviz" args="-d $(find some_rfid)/rviz_config/urdf.rviz"/>-->
  <node name="rviz" pkg="rviz" type="rviz" args=""/>


This is all I see when I am launching. Hope anyone can explain?

Hi @mamojiz97 ,

Try to comment out the Rviz node in the launch file and try launching Rviz in a new terminal with
rosrun rviz rviz.
If that works correctly, then uncomment the rviz node line in the launch file and remove the args="" tag.
So <node name="rviz" pkg="rviz" type="rviz" args=""/> would change to
<node name="rviz" pkg="rviz" type="rviz"/>

Try this and let me know if it worked for you.


Hi @girishkumar.kannan

It works even without making the Rviz node to a comment in the launch file and launching rosrun rviz rviz.

I also tried to do as you suggested, to remove the args=" " tag and it still did not work.

Hi @girishkumar.kannan
So, I was iterating a few ways to launch the rviz file.

Initially I was launching it roslaunch some_rfid visualize.launch and it did not work.

Then I used roslaunch some_rfid visualize.launch model:='$(find some_rfid)/urdf/rfidbot.urdf' and it worked.

I have 2 questions as a follow up:

  1. Why did it not work with initial way of launching the rviz file?

  2. Once I launched the rviz file, I received a message shown below:

    Could you explain what it means?

Thank You

Hi @mamojiz97 ,

I understand that you are working on your own project - something relating to a robot with RF identification device.

The usage is mentioned in the launch file itself, in this line:
<!-- USE: roslaunch some_rfid visualize.launch model:='$(find myrobot_package)/urdf/myrobot.urdf' -->
That is why your launch file works correctly with the model:=... argument.

That is because your launch file required a reference to the robot’s urdf file.

This you can ignore, it has something to with (Gnome) display driver(s).


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.