Rviz2 no tf data

Hello guys,

I have installed ROS2 Foxy on a VM (Oracle VirtualBox) running on Ubuntu 20.04 and I am trying to run a very simple navigation with my Turtlebot3 Burger robot but I can’t make it work.

The thing is that I have also set up a PC (not VM) on Ubuntu 20.04 (same setup ROS2 Foxy) and the same scripts run with no problem…

Here is what happens:
I run the bring up, then the localization server and then the rviz2. When I run the rviz2 I see an error on the fixed frame “No tf data”, I can also see that TF frames are just showing “All Enables = True”, there is no “base_footprint, base_link, etc, etc” like there is on the PC.

Then I run the path_planner and I get an error that I also don’t get on the other PC: “tf error: Invalid frame ID “map” passed to canTransform argument target_frame - frame does not exist”.

Do you have any ideas what I am missing here? How can the same scripts run on the PC and not on the VM? What should I look for?

I am attaching a screenshot of the problematic RVIZ2 to take a look.

Than you for your time,

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.