URDF issue after launching rviz


I was doing the course on " Creating the Visual Robot Model with URDF" But I found problem few problems after launching Rviz.

  1. The joint state publisher gui is completely blank.
  2. I can’t increase the size of the robot. I tried using all the option below but robot movement is also not happening with left arrow/right arrow and shift key.

Please help.

You will have to be a bit more specifu I’m affraid. What unt are you in? What coude are you executing? How are you executing this code? Please give us more information to be able to help you correctly, otherwise we are just guessing on what might be the problem.

Please find the answer of your question below:
What unt are you in?
Ans: I am in “unit 1” urdf module.
What code are you executing?
Ans: I am executing below code:
"roslaunch my_mira_description urdf_visualize.launch model:=’$(find my_mira_description)/urdf/mira_simple.urdf’
How are you executing this code?
Ans: I am executing the above command in the webshell and launching the Rviz. In Rviz I am facing that state publisher is blank.
Please let me know if you need any further information.

Soumik Sur.

If the state publisher does not appear maybe it is missing the “Spawn” lines which calls the robot state publisher in your Launch file. Or maybe you have forgot to add this line in your launch file, or entered with wrong arguments. Sometimes bad identation can occur. The robot state publisher if I am not wrong also depends from joint state publisher. So the joint state publisher must be well correctly configured and also declared in your launch file. However to see in rviz I imagine you just need send a “fake joint state publisher” values and not configure a controller. If I were you I would try to copy a launch file model which is already working and later adapt to your robot. Is usually worked for me when I was studying the Urdf module.