Urdf qui̇z fault

I regret to say that the training of the URDF course is not as descriptive as ros basic in 5 days course. I get an error like the following in the URDF quiz. I would be glad if you could help. The initialization files required to start a urdf file are not in the solution of the gurdy quiz. There are only urdf file, gurdy_control.yaml file and my_gurdy.launch file there . But there is no urdf file in the my_gurdy.launch boot file. Why?

Hi @kagizman

judging from the Error messages, it looks like you didn’t copy the .dae files into your package

I copied these dae files.

I am getting this error in rviz.

Your tf broadcaster doesnt seem to broadcast the transformations. Perhaps you are missing something in the urdf files.

I just copied and pasted the gurdy.urdf file. But ı still get the same error. Could there be a problem in the solution of the urdf quiz?

@bayodesegun can you take a look? I’m not that familiar with the quiz setup


The aim of the solution is not to give you something that works hook, line, sinker! Just meant to be a pointer to how things could be done. Besides, in copy/paste, there’s a tendency to have a mismatch of names/paths in a couple of places so it hardly works out of the box.

Now the error says the files cannot be found, meaning they are either not there or the paths are wrong. I’ll suggest you have a closer look at this. It’s the same problem in Rviz.

I’am so sorry but ı didn’t find any mismatch of names/paths. When I run just the URDF file with the command below, there is no problem. The robot model appears completely on rviz.

roslaunch my_gurdy_description urdf_visualize.launch model:=’$(find my_gurdy_description)/urdf/gurdy.urdf’

urdf_visualize.launch file is below.

  <arg name="model" default=""/>
  <param name="robot_description" command="cat $(arg model)" />
  <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
    <param name="use_gui" value="TRUE"/>
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="state_publisher"/>
  <node name="rviz" pkg="rviz" type="rviz" args=""/>

So I don’t think the problem is in the urdf file. But I also don’t know what it is caused by.

What exactly is generating the error you are seeing? When does it happen and what command did you run before that?

I showed the error I received above. I don’t know how I can explain more. I take the same error both in quiz solution and Execise 3.2 solution. I never change the urdf and launch files provided in the solution. But as you can see, I get an RViz error like above.

You can explain more by stating step by step how the error happened, including the following points among others:

What exactly were you doing when this error happened? What commands did you run before or after? Did it happen when you try to submit the Quiz?

How is this command different from the one you ran above? What is different about the context?

I see that you submitted the quiz once and then viewed the solution, suggesting you had your own files at some point and then copied in the files in the solution. Don’t you think there could have been a mixup somewhere?


I just tried the solution and it worked.
Maybe I missed something but here I post the my_gurdy_package with the spawn_v1 and v2.

Hope it helps:


roslaunch my_gurdy_description spawn_gurdy.launch