Exercise U2-2 gazebo not showing as expected

I followed the given solution for this exercise but I couldnt get the desired result. As you can see there is no body, head and eyes showing in the gazebo. What can be wrong? I even copy pasted the given solution but still doesn’t work. I also have the meshes saved.

It looks like you have not set the files with the daes descriptions. Did you put the following files at /home/user/catkin_ws/my_mira_description/models/mira/meshes/:

  • mira_eye_v4.dae
  • mira_head_v5.dae
  • mira_body_v3.dae

It is there.

It is still not working. Also not working for the other exercises.

It’s been 6 days and still no reply.

I apologize for the delay.
The problem you have on not visualizing the meshes is due to two things:

  1. You must copy the models using the command:
    cp -r /home/user/catkin_ws/src/my_mira_description /usr/share/gazebo/models/
  2. There is a permission problem inside the academy when issuing that command. Tomorrow morning will be solved. I will put a comment here when solved

I already tried the above steps the day I created this question but still it doesnt’ work.

Yes I know Apurva. There is a problem with the permissions on writing at the /usr/share/gazebo/models/. We are working right now on solving that issue. Let me write down here when it is solved

1 Like

Hi @apurva.mramdham,

the issue has been solved and it’s now on production.

Now the /usr/share/gazebo/models/ folder has the right permissions.

1 Like

Hi @ralves,

I meet the same problem could you please give my folder the right permission also? or I can fix this issue by myself?

Hi @wang.jianshu,

I’ve just checked myself and the permissions seem to be ok.

I tested with the commands below:

cd /usr/share/gazebo/models/
ls -lh
mkdir just_testing
ls -lh

Could you tell us which command exactly you tried and the error message it raised?
If there are permission problems, you could just try to execute the commands aforementioned (or the ones you are trying) with sudo.

Please let us know in case you need further assistance.

Hi @ralves
When I run this command:
roslaunch my_mira_description spawn_mira_no_controllers.launch

it does not show the mesh part correctly.
I think it should be the same problem.

Hi @ralves,
As you can see, I change visual of only one part, but it still not showing that part correctly, it looks like gazebo cannot read the dae file correctly, by the way I have given dae files permission to execute, by using command “chomd +x”.

update: I fixed this problem by this command:

cp -r /home/user/catkin_ws/src/my_mira_description /usr/share/gazebo/models/


I have the similar problem. I followed all and setup correctly but meshes are not shown.

I posted separate question on the same question.

Best regards
Igor V