Large robot URDF not display properly in rviz and gazebo

Hi there,
I was trying to create my robot model in Gazebo. I imported an STL file of my robot from Solidworks. The dimension of the robot is about 1000mm * 1000mm * 600mm.

It was way too big in RVIZ and gazebo that I cannot see the TF axis and cannot zoom properly.
Is there a way to fix this issue??



This happens becaus ethe units in Gazebo are meters, if you didnt rescale it probably the dimensions that in SW were mm, Gazebo thinks they are meters.

You have two options:

  1. You open the STL in blender and rescale it to be the correct size
  2. You apple the scale tg in the meshes n the URDF/XACRO/SDF model that you are using .

You decide. My personal recommendation is to have the meshes at the correct scale, it makes it easier to work on the long run

1 Like